PHP 5.4.36 Released

Problems?

Table of Contents

add a note add a note

User Contributed Notes 1 note

up
-17
hvozda at ack dot org
8 years ago
When using --with-gd, jpeg support is *not* enabled by default even if the libs and headers are in /usr/lib and /usr/include.  Yet, if they are missing, GD will not build.

Oddly, examine the output from configure will show that libjpeg was actuly found and tested.

This happens with v4.4.4 of php on these platforms: RHEL v2.1, RHEL v3, CentOS v2.1 or CentOS v4.3.

On those platforms, it's *important* that --with-jpeg-dir be *before* --with-gd.  If it's not, GD won't build with jpeg support as if --with-jpeg-dir had never been specified.

It's also a "feechure" that gd_info() doesn't list jpeg support if it wasn't built with it.  However, if it is built with it, it will list it as "enabled" of course :-/
To Top